Restricted data access for both Facebook and Instagram
Incident Report for quintly
Resolved
After a few days of intensive monitoring we are happy to announce that we have not identified any remaining issues. We are closing this incident. In case of related questions, please reach out to our team at support@quintly.com .
Posted Apr 11, 2018 - 07:48 UTC
Monitoring
We have done further enhancements to our product to reflect the changes we have applied:
1. You can quickly identify if an Instagram profile is a personal or a business account (Profiles section). More help for personal accounts is provided on the profile's detail page with help about how to transition your personal into a business account on Instagram.
2. We are showing a proper warning when you try to give our tool private messages permission for your Facebook Page. For new Pages this is not possible for now because Facebook has temporarily shut off this permission for third party developers. We'll see how Facebook moves on with this over the next days.

Beside the interface adjustments we are happy to announce that also Instagram imports for public page and post data are running smoothly again.

Finally we have reached stable state again for Instagram and our product is back on track. We keep this incident open for another few days just in case there are further related issues coming up. We will be monitoring our systems closely over the next days in that regard.
Posted Apr 06, 2018 - 20:54 UTC
Update
We are happy to announce that you can add new Instagram profiles again. Please note from now onward, only Instagram Business Accounts can be tracked and you will need to use the profile's URL to add a profile within our Add Profile dialog.

As a final step we are stabilizing Instagram imports further. We are close to finally resolve this incident.
Posted Apr 06, 2018 - 14:15 UTC
Update
We are still working hard on enabling new Instagram profiles to be added to our platform again. Follower count imports for a good chunk of Instagram Business Accounts have been finished using the new Instagram Graph API, but we are still experiencing strict rate limits from Facebook's side with this new API. Our team is working hard on getting this resolved. We keep you posted. At this point we expect that adding new Instagram Business Accounts will be available again in the first half of the day tomorrow, followed by stabilizing imports for both follower and post data to find our path back to a stable situation for importing Instagram public data.
Posted Apr 05, 2018 - 22:43 UTC
Update
After further investigation we can confirm that you can still connect your Facebook Pages with Insights in our tool, but you can't provide permission to access private messages of the Page. Make sure to select "Basic Facebook Insights" within our tool's Insights connection process (without Inbox). Facebook has paused allowing people to give access to their Page's private messages for now. If you have given our product access to read your Page's private messages before, you can still use related metrics (e.g. Private Conversations Table). Facebook is tracking that issue at https://developers.facebook.com/status/issues/104197713763517/ .
Posted Apr 05, 2018 - 07:42 UTC
Update
Currently new Facebook Pages can't be connected with Insights within our tool because of breaking changes to Facebook's Graph API. We are working on a resolution and will follow up here with further news.
Posted Apr 05, 2018 - 07:19 UTC
Update
Currently we had to stop importing of public Instagram data (follower counts and post data) as Facebook has shut off the former Instagram API with immediate effect.

Our team is working on switching to the new Instagram Graph API to allow full imports for Instagram Business Accounts. It won't be possible to track Instagram Non-Business Accounts (User Accounts) going forward. We keep you updated here about the progress of our team and once imports are running smoothly for Instagram Business Accounts.

Please note that this does not cover analyses via Instagram Insights for your owned channels. Instagram Insights based metrics (https://app.quintly.com/discover/metrics/search?orderBy=mostUsed&search=id-6&search=id-14) are not affected.
Posted Apr 04, 2018 - 21:03 UTC
Update
As Facebook shut off the Search API for Pages with immediate effect, we can't provide free-text search for Facebook Pages within our Add Profile dialog anymore. For Facebook Pages you have to use the direct Page URL (e.g. https://www.facebook.com/quintly) instead to add new Facebook Pages for now.

For Instagram adding new profiles within our tool is not possible right now as Facebook shut off the former Instagram API with immediate effect. We are working on adding Instagram profiles by providing the direct profile URL (e.g. https://www.instagram.com/quintly/), similar to adding new Facebook Pages, as fast as possible. We keep you updated here.
Posted Apr 04, 2018 - 20:58 UTC
Investigating
Facebook has announced to restrict data access on both Facebook and Instagram. The official announcement can be found at https://newsroom.fb.com/news/2018/04/restricting-data-access/ and https://developers.facebook.com/blog/post/2018/04/04/facebook-api-platform-product-changes/ . We are investigating how this affects our product and will keep you updated here.
Posted Apr 04, 2018 - 20:47 UTC