Increased errors importing data for Facebook and Instagram
Incident Report for quintly
Resolved
This incident has been resolved.
Posted Jun 09, 2020 - 17:45 UTC
Update
While the majority of errors has disappeared and imports are stable, in very rare cases there can still be import issues for the Insights of Instagram business accounts. Again, due to frequent imports, you can expect data to be complete. For transparency reasons we still share with you the bug report at Facebook covering this topic: https://developers.facebook.com/support/bugs/492909894930553/ .

We will only resolve this incident once also this rare error is fixed.
Posted Mar 20, 2020 - 09:08 UTC
Monitoring
Facebook has been confirming that all similar errors have the same source. As a consequence all bugs have been merged into https://developers.facebook.com/support/bugs/643788149784639/ . Several people reported seeing less errors since this morning and we are happy to confirm that the error rate of imports for ourselves has been dropping from 20% to around 1%. Combined with frequent imports data sets can be expected to be complete again. We are still awaiting final confirmation by Facebook and will closely monitor error rates in the next hours. We will keep this incident open up until we can permanently confirm no more errors.
Posted Mar 18, 2020 - 08:57 UTC
Investigating
Using Facebook's Graph API we are experiencing sporadic errors across most of their endpoints affecting our data imports on both page- and post-level for Facebook Pages and Instagram accounts. According to our monitoring this currently affects up to 20% of all data imports and errors seem to be sticky for a while to then disappear, overall resulting in a very unreliable behavior of the Graph API.

On Facebook's side there are several bug reports covering this topic, some of them created by ourselves to cover our specific cases beside the more general ones. Please find the most popular bug report and one of our own ones below:
https://developers.facebook.com/support/bugs/643788149784639/
https://developers.facebook.com/support/bugs/662301774310981/

We are urgently awaiting a fix by Facebook. While waiting for a fix, we run imports at an import interval of 6 hours or less for all Facebook and Instagram related data imports. Some imports, e.g. Instagram stories, we do run every 30 minutes. Frequent imports help closing gaps in data because of the chance to not hit the error.

We transparently share with you the import time of every single post, video or story. This information is available for all of our data sources. Please make use of this information to know exactly when a specific object has been refreshed.

We will be updating this incident report as soon as new information is available. Please don't hesitate to reach out to our support at support@quintly.com for more specific questions.
Posted Mar 17, 2020 - 10:17 UTC