Instagram Insights not working as expected due to unannounced breaking change on Facebook's permission model
Incident Report for quintly
Resolved
Facebook stated that they won't fix the issues regarding the Instagram Business Account authentication for now. We will close this incident as we don't expect a solution soon. Facebook recommends a workaround in their bug ticket https://developers.facebook.com/support/bugs/177912116363088/ that involves converting the Instagram account back to a personal and then back to a business account. Please be aware that by doing so, all media insights are lost to the date of the conversion. This will affect not only the data you see in quintly, but also the data in your Instagram App. If you have problems authenticating your Instagram account with quintly, please reach out to our customer support.
Posted Aug 20, 2018 - 09:27 UTC
Update
We are happy to see the initial Facebook bug tracked at https://developers.facebook.com/support/bugs/217599355760582/ has been fixed and does resolve problems for some customers and us not requiring business management permission anymore as a workaround.

While the bug mentioned above was fixed by Facebook, there is another bug still causing authentication issues for some Instagram Business Accounts. This additional bug is tracked at https://developers.facebook.com/support/bugs/177912116363088/ and still affects a smaller share of Instagram Business Accounts. For that reason we have decided to keep this incident open until we can be sure that all Instagram Business Accounts can reliably connect their Insights within our tool. We'll share more information as Facebook shares more news around this bug.
Posted Aug 10, 2018 - 19:27 UTC
Update
We have found evidence that there are still problems for some customers connecting their Instagram Business accounts in quintly, even with granting us the additional business_management permission. This fits with some reports on the bug report: https://developers.facebook.com/support/bugs/217599355760582/?disable_redirect=0
We are still waiting for a response from Facebook.
WARNING: There is a proposal for a workaround floating around, converting the Instagram account back to a private profile and then back to a business account again. WE DISCOURAGE from doing this, or otherwise you will lose access to your Instagram Insights history, not only in quintly but highly likely also directly in your Instagram account. The Insights history gets build up from the day of the last business account transformation onwards.
Posted Aug 01, 2018 - 14:39 UTC
Monitoring
Due to a breaking change on Facebook's permission model, the permissions granted by our customers are no longer enough to retrieve Instagram Insights data. We have released an update that asks for the missing additional permission. If you are affected, please login to quintly and reauthenticate your Instagram accounts to get access to Instagram Insights.
We believe that this incident is related to this bug report: https://developers.facebook.com/support/bugs/217599355760582/?disable_redirect=0
Posted Jul 25, 2018 - 09:28 UTC