Instagram Page Insights returning zero values for weekly and monthly intervals
Incident Report for quintly
Resolved
Today Facebook/Instagram has been rolling out a patch and we can confirm all weekly and 28 day values showing correct numbers again. At quintly we have been re-running all historic imports to refresh numbers and all data is complete again. Thanks a lot for your patience on this!

You can find Facebook/Instagram's final response on this issue at: https://developers.facebook.com/support/bugs/410323517047669/
Posted Jan 08, 2021 - 16:42 UTC
Update
Sadly there is still no fix or work-around available. The topic got more attention by other developers facing the same issue. We hope to see a resolution by Facebook/Instagram this week.
Posted Jan 04, 2021 - 08:58 UTC
Identified
Facebook has now confirmed this bug and the ticket is now with the product team. We hope to see this resolved very soon. The up to date bug report to follow is: https://developers.facebook.com/support/bugs/410323517047669/
Posted Dec 22, 2020 - 16:15 UTC
Update
While Facebook responded about 2 hours ago (https://developers.facebook.com/support/bugs/1098756200558522/?comment_id=1101173456983463), there is still no fix for this issue. Additional information was provided to Facebook and we hope them to resolve this soon.
Posted Dec 21, 2020 - 10:45 UTC
Investigating
Instagram is currently facing a bug returning zero values for weekly and monthly (28 day) intervals for all page-level Insights metrics of Instagram profiles (e.g. Impressions, Reach). This does not affect daily intervals. There is actually not a lot we can do on our side as there are no work-arounds available. The bug seems to be very fresh and there is already an open bug report with Facebook at https://developers.facebook.com/support/bugs/1098756200558522/ . We hope to see a response very soon.

For quintly this affects data source instagramInsights. As we do update values of the last 30 days in a rolling window fashion with every import, this currently affects all reports based on page-level Instagram Insights data with values showing zero for the last 30 days (e.g. affecting months November and December 2020 for a monthly interval).

We keep you updated via this incident report.
Posted Dec 18, 2020 - 10:50 UTC