Issues importing public Pinterest data
Incident Report for quintly
Resolved
We have received an answer from Pinterest's Business support. They confirmed for data privacy reasons they no longer allow third parties to access public data. As this breaks the competitive benchmarking use case we have decided to remove Pinterest from quintly.

All default metrics from the Discover section will be immediately removed. Pinterest metrics on your dashboards will be deprecated on the 1st of January 2020. Please note, you are still able to access historic data, but data isn't refreshed anymore. We suggest you export the data if you wish to reference it at another time.

As you will no longer be able to track the Pinterest profiles added, please reach out to your account manager or support to discuss your account.
Posted Nov 08, 2019 - 11:45 UTC
Update
Sadly we can still confirm importing public Pinterest data is not working as expected. In the meanwhile our request with detailed explanations has been forwarded to the appropriate team at Pinterest and we are awaiting a response soon. Further updates will be shared here as they come in.
Posted Oct 29, 2019 - 09:54 UTC
Investigating
We are currently investigating problems with the import of public Pinterest data affecting our data sources pinterest, pinterestPins and pinterestBoards. Today early morning access to the Pinterest API importing those public data sets stopped working. Errors indicate we are not allowed to import data for any Pinterest profile as it is required to support competitive benchmarking use cases. There has been no upfront notice of changes by Pinterest. You are still able to access Pinterest data that was collected up until yesterday within our tool, but data isn't refreshed anymore.

We have already reached out to Pinterest's developer support to further clarify. We'll keep you updated here on this incident report.
Posted Oct 25, 2019 - 12:53 UTC