Private statistics disconnections
Incident Report for quintly
Resolved
We have been monitoring the situation and can finally announce this incident is resolved.

While this change by Facebook came unexpected - with the more specific permissions being in place earlier - we decided to directly make use of them when authenticating for private statistics in quintly. For most private statistics use cases we are now asking for more specific read-only permissions instead of former manage_pages, e.g. pages_read_engagement instead of manage_pages. We will publish a separate product update about this sharing more details.
Posted Jun 10, 2020 - 09:03 UTC
Monitoring
We can finally confirm that all private stats connections have been properly re-connected. We are closely monitoring the system and will try to find out why this change was applied by Facebook today before closing this incident.
Posted Jun 09, 2020 - 22:13 UTC
Identified
It looks like Facebook has been rolling out updates regarding the split of permission manage_pages into four more specific permissions earlier than expected for older API versions. You can find more information about this change at https://developers.facebook.com/docs/graph-api/changelog/version7.0#permissions . The changelog announces that code changes for existing solutions need to be applied by May 2022, but somehow this change became effective today. It is unclear yet why this was happening today.

As a direct result all private stats connections for Facebook Pages and Instagram Business Accounts within quintly were temporarily detected as not fulfilled. Our team has been jumping on this immediately and all connections are refreshed right now based on the four new more specific permissions that Facebook now returns instead of manage_pages. We expect all issues with private statistic connections to be resolved within the next hour.

We keep sharing updates on this ticket and will notify once all connections have been properly reactivated within quintly.
Posted Jun 09, 2020 - 18:03 UTC